]> git.pld-linux.org Git - packages/crossmingw32-libsigc++.git/blame - crossmingw32-libsigc++.spec
- updated to 2.10.0
[packages/crossmingw32-libsigc++.git] / crossmingw32-libsigc++.spec
CommitLineData
1a9246c6
JB
1Summary: The Typesafe Signal Framework for C++ - MinGW32 cross version
2Summary(pl.UTF-8): Środowisko sygnałów z kontrolą typów dla C++ - wersja skrośna dla MinGW32
67b44d4b
JB
3%define realname libsigc++
4Name: crossmingw32-%{realname}
8c977c89 5Version: 2.10.0
eea5dec6 6Release: 1
67b44d4b 7License: LGPL v2.1+
066b4b18 8Group: Development/Libraries
8c977c89
JB
9Source0: http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.10/%{realname}-%{version}.tar.xz
10# Source0-md5: 70bcbde2c900e4925d6ef4bf50954195
dec16728 11URL: http://libsigc.sourceforge.net/
12BuildRequires: autoconf >= 2.59
951a73e1 13BuildRequires: automake >= 1:1.9
eea5dec6 14BuildRequires: crossmingw32-gcc-c++ >= 1:4.6
e27607ce 15BuildRequires: libtool >= 2:2.0
dec16728 16BuildRequires: m4
8c977c89 17BuildRequires: mm-common >= 0.9.10
dec16728 18BuildRequires: perl-base
1a9246c6 19BuildRequires: pkgconfig
951a73e1
JB
20BuildRequires: tar >= 1:1.22
21BuildRequires: xz
eea5dec6 22Requires: crossmingw32-gcc-c++ >= 1:4.6
dec16728 23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%define no_install_post_strip 1
26
27%define target i386-mingw32
28%define target_platform i386-pc-mingw32
dec16728 29
30%define _sysprefix /usr
31%define _prefix %{_sysprefix}/%{target}
6986ab9d
JB
32%define _libdir %{_prefix}/lib
33%define _pkgconfigdir %{_prefix}/lib/pkgconfig
066b4b18 34%define _dlldir /usr/share/wine/windows/system
dec16728 35%define __cc %{target}-gcc
36%define __cxx %{target}-g++
7e12b981 37%define __pkgconfig_provides %{nil}
b8988822 38%define __pkgconfig_requires %{nil}
dec16728 39
96d9454a
JB
40%ifnarch %{ix86}
41# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
42%define optflags -O2
43%endif
e27607ce 44# -z options are invalid for mingw linker, most of -f options are Linux-specific
96d9454a 45%define filterout_ld -Wl,-z,.*
79081b3a 46%define filterout_c -f[-a-z0-9=]*
e27607ce 47%define filterout_cxx -f[-a-z0-9=]*
96d9454a 48
dec16728 49%description
50This library implements a full callback system for use in widget
51libraries, abstract interfaces, and general programming. Originally
52part of the Gtk-- widget set, libsigc++ is now a seperate library to
53provide for more general use. It is the most complete library of its
54kind with the ablity to connect an abstract callback to a class
55method, function, or function object. It contains adaptor classes for
56connection of dissimilar callbacks and has an ease of use unmatched by
57other C++ callback libraries.
58
1a9246c6 59This package contains cross MinGW32 version.
708b30c2 60
a0719c45
JR
61%description -l pl.UTF-8
62Ta biblioteka jest implementacją pełnego systemu callbacków do
63używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
64ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
65Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
66przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
67łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
68obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
69callbacków.
dec16728 70
1a9246c6 71Ten pakiet zawiera wersję skrośną MinGW32.
708b30c2 72
066b4b18 73%package static
1a9246c6
JB
74Summary: Static libsigc++ library (cross MinGW32 version)
75Summary(pl.UTF-8): Statyczna biblioteka libsigc++ (wersja skrośna MinGW32)
066b4b18
JB
76Group: Development/Libraries
77Requires: %{name} = %{version}-%{release}
78
79%description static
1a9246c6 80Static libsigc++ library (cross MinGW32 version).
066b4b18
JB
81
82%description static -l pl.UTF-8
1a9246c6 83Statyczna biblioteka libsigc++ (wersja skrośna MinGW32).
066b4b18
JB
84
85%package dll
86Summary: DLL libsigc++ library for Windows
87Summary(pl.UTF-8): Biblioteka DLL libsigc++ dla Windows
88Group: Applications/Emulators
89Requires: wine
90
91%description dll
92DLL libsigc++ library for Windows.
93
94%description dll -l pl.UTF-8
95Biblioteka DLL libsigc++ dla Windows.
96
dec16728 97%prep
67b44d4b 98%setup -q -n %{realname}-%{version}
dec16728 99
100%build
101%{__libtoolize}
1a9246c6 102%{__aclocal} -I build
dec16728 103%{__autoconf}
104%{__automake}
105%configure \
178e282c 106 --target=%{target} \
107 --host=%{target} \
8c977c89 108 --disable-silent-rules \
178e282c 109 --enable-static
110
8c977c89 111%{__make}
dec16728 112
113%install
114rm -rf $RPM_BUILD_ROOT
115
116%{__make} install \
117 DESTDIR=$RPM_BUILD_ROOT
118
066b4b18
JB
119install -d $RPM_BUILD_ROOT%{_dlldir}
120mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
121
122%if 0%{!?debug:1}
123%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
124%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
125%endif
126
1a9246c6 127%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{devhelp,doc}
066b4b18 128
dec16728 129%clean
130rm -rf $RPM_BUILD_ROOT
131
132%files
133%defattr(644,root,root,755)
eea5dec6 134%doc AUTHORS ChangeLog NEWS README
066b4b18
JB
135%{_libdir}/libsigc-2.0.dll.a
136%{_libdir}/libsigc-2.0.la
137%{_libdir}/sigc++-2.0
723599ec 138%{_includedir}/sigc++-2.0
67b44d4b 139%{_pkgconfigdir}/sigc++-2.0.pc
066b4b18
JB
140
141%files static
142%defattr(644,root,root,755)
143%{_libdir}/libsigc-2.0.a
144
145%files dll
146%defattr(644,root,root,755)
147%{_dlldir}/libsigc-2.0-*.dll
This page took 0.147773 seconds and 4 git commands to generate.